Using typedefs to make types with long namespaces short and more readable

May 10, 2012 at 4:50 PM
Edited May 10, 2012 at 4:52 PM

I wonder if this is more readable (copy the code to VS to see the sample):

 

 

 

concurrency::task<Windows::Foundation::Collections::IVectorView<Windows::Storage::BulkAccess::FileInformation^>^> fileInformationVecorViewCollectionTask_t

 

fileInformationVecorViewCollectionTask_t GetPhotosAsync(Platform::String^ query, unsigned int

 

fileInformationVecorViewCollectionTask_t GetPhotosAsync(Windows::Storage::Search::IStorageFolderQueryOperations^ folder, Platform::String^ query, unsigned int

 

fileInformationVecorViewCollectionTask_t GetAllPhotosAsync(Windows::Storage::Search::IStorageFolderQueryOperations^ folder, Platform::String

 

^ query);

maxNumberOfItems = 10);

 

 

maxNumberOfItems = 10);

 

 

;

 

 

typedef

May 19, 2012 at 4:41 PM

Or just using the

namespace WFC = Windows::Foundation::Collections;

syntax?

May 20, 2012 at 5:02 AM

We are going to make a final push through this before we get release the final version. This is on the list.